1#!/usr/bin/make -f
2# -*- makefile -*-
3
4# Uncomment this to turn on verbose mode.
5#export DH_VERBOSE=1
6
7CFLAGS = -g -Wall
8ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
9 CFLAGS += -O0
10else
11 CFLAGS += -O2
12endif
13export CFLAGS
14
15#
16# On PowerPC we compile against the hand-crafted assembly, on all
17# other architectures we compile against GPL'ed sha1 code lifted
18# from Mozilla. OpenSSL is strangely licensed and best avoided
19# in Debian.
20#
21HOST_ARCH=$(shell dpkg-architecture -qDEB_HOST_ARCH)
22ifeq (${HOST_ARCH},powerpc)
23 export PPC_SHA1=YesPlease
24else
25 export MOZILLA_SHA1=YesPlease
26endif
27
28
29PREFIX := /usr
30MANDIR := /usr/share/man/
31
32SRC := ./
33DOC := Documentation/
34DESTDIR := $(CURDIR)/debian/tmp
35DOC_DESTDIR := $(DESTDIR)/usr/share/doc/git-core/
36MAN_DESTDIR := $(DESTDIR)/$(MANDIR)
37
38build: debian/build-stamp
39debian/build-stamp:
40 dh_testdir
41 $(MAKE) prefix=$(PREFIX) all doc
42 touch debian/build-stamp
43
44debian-clean:
45 dh_testdir
46 dh_testroot
47 rm -f debian/build-stamp
48 dh_clean
49
50clean: debian-clean
51 $(MAKE) clean
52
53install: build
54 dh_testdir
55 dh_testroot
56 dh_clean -k
57 dh_installdirs
58
59 make dest=$(DESTDIR) prefix=$(PREFIX) mandir=$(MANDIR) install install-tools install-doc
60
61 mkdir -p $(DOC_DESTDIR)
62 find $(DOC) '(' -name '*.txt' -o -name '*.html' ')' -exec install {} $(DOC_DESTDIR) ';'
63
64 dh_movefiles -p git-tk
65 dh_movefiles -p git-core
66 find debian/tmp -type d -o -print | sed -e 's/^/? /'
67
68binary: build install
69 dh_testdir
70 dh_testroot
71 dh_installchangelogs
72 dh_installdocs
73 dh_installexamples
74# dh_installmenu
75# dh_installdebconf
76# dh_installlogrotate
77# dh_installemacsen
78# dh_installpam
79# dh_installmime
80# dh_installinit
81# dh_installcron
82# dh_installinfo
83 dh_installman
84 dh_link
85 dh_strip
86 dh_compress
87 dh_fixperms
88# dh_perl
89# dh_python
90 dh_makeshlibs
91 dh_installdeb
92 dh_shlibdeps
93 dh_gencontrol
94 dh_md5sums
95 dh_builddeb
96
97.PHONY: build clean binary install clean debian-clean